Lecture prepared by Asst. Prof.  Baburam Bhattarai        
Lecture 4, 5 & 6
                   July 2007

Drawing Objects


Rectangle 

Command : _Rectang or type rec
Creates a rectangle
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width] : Use one of the point fixing methods
Specify other point or [Dimensions] : Use one of the point fixing methods or type D for dimensions options 
Dimensions

Specify length for rectangles: Enter length value 
Specify width for rectangles: Enter width value
Chamfer (it helps to chamfering the corner of a rectangle)
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: C
Specify first chamfer distance for rectangles <0>: Enter a value
Specify second chamfer distance for rectangles <0>: Enter a value
Then repeat the same process as above for rectangle of required chamfered.
Elevation (it helps to increase or reduce the height of rectangle, can be seen on 3d only) 
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: E

Specify the elevation for rectangles <0>: Enter a value
Then repeat the same process as above for rectangle in required elevation.
Fillet (it helps to round off the corner of the rectangle)
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: F
Specify the fillet radius for rectangles <0>: Enter a value
Then repeat the same process as above for rectangle of required fillet.

Thickness (it helps add the thickness of the rectangle, can be seen on 3d only)
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: T
Specify the thickness for rectangles <0>: Enter a value
Then repeat the same process as above for rectangle of required thickness.

Width (it helps to add the line width of the rectangle)
Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: W

Specify line width for rectangles <0>: Enter a value
Then repeat the same process as above for rectangle of required line width.

Arc

Draw – Arc or type a
Creates an arc

Arc command allows you to create an arc segment. Arcs created by AutoCAD 2002 are circular arcs, which form a part of a circle. There are different methods of creating an arc as illustrated below. The default method is to specify the circumference with three points.  

Start point 

This specifies the start point of arc.

Command : _arc Specify start point of arc or [Center] : Use one of the point fixing methods
Second Point 

Draw – Arc – 3 points 

This draws an arc using three specific points along the conference of the arc. The first and the third points form the end points of the arc. The second point can be any point on the circumference of the arc. 

Specify second point of arc or [Center/End] : Use one of the point fixing methods
Specify end point of arc: Use one of the point fixing methods
Center 

Specifies the center of the arc segment.

Specify second point of arc or [Center/End] : C 

Specify center point of arc: Use one of the point fixing methods
Specify end point of arc or [Angle/chord Length] : Specify a point or enter an option
End Point

Using the center point, draw an arc counterclockwise from the start point that falls on an imaginary ray from the center point through the end point. 

Angle 

Draw- Arc- Start, Centre, Angle

The angle option draws an arc counterclockwise from the start point using a center point with a specified included angle. If the angle is negative, AutoCAD 2002 draws an arc clockwise.

Specify included angle : Specify an angle

Chord Length

Draw- Arc- Start, Centre, Length

Draws either a minor or a major arc.

Specify length of chord : Specify a chord length 

If the chord length is positive, AutoCAD 2002 draws the minor arc counterclockwise from the start point and the chord length to compute the ending angle. If the chord length is negative, AutoCAD 2002 draws the major arc counterclockwise from the start point and uses chord length to compute the ending angle. 
Start, End Method

End 

Specify second point of arc or [Center/End] : E

Specify end point of arc : Use one of the point fixing methods
Specify end point of arc or [Angle/Direction/Radius] : Use one of the point fixing methods or enter an option
Center Point

Using the center point draws an arc counterclockwise from the start point to an end point that falls on an imaginary ray drawn from the center point through the second point specified.  

Angle

Draw- Arc- Start, End, Angle

Draws an arc counterclockwise from the start point to an end point with a specified included angle. If the angle is negative, AutoCAD 2002 draws an arc clockwise.

Specify included angle : Specify an angle

Direction

Draw- Arc- Start, End, Direction
Begins the arc tangent to a specified direction. It creates any arc, major or minor, clockwise or counterclockwise, beginning with start point and ending at end point. AutoCAD 2002 determines the direction from the start point.

Specify tangent direction for the start point of arc : Specify a direction

Radius

Draw- Arc- Start, End, Radius

Draws the minor arc counterclockwise from the start point, to an end point. If the radius is negative, AutoCAD 2002 draws the major arc.

Specify radius of arc : Specify a radius

Center

Specifies the center of the circle of which an arc is a part. 

Command : _arc Specify start point of arc or [Center] : c

Specify center point of arc: Use one of the point fixing methods
Specify start point of arc : Use one of the point fixing methods 
Specify end point of arc or [Angle/chord Length] : Use one of the point fixing methods or enter an option
End Point 

Draw- Arc- Center, Start, End

Using the center point draws an arc counterclockwise form the start point, so that falls on an imaginary ray from the center point through the end point.
Angle

Draw- Arc- Center, Start, Angle

Draws either a major or minor arc. If the chord length is positive, AutoCAD 2002 draws the minor arc counterclockwise from the start point and chord length to compute the ending angle. If the chord length is negative, AutoCAD 2002 draws the major arc counterclockwise from the start point and chord length to compute the ending angle.

Specify length of chord : Specify a chord length

Ellipse 

Draw > Ellipse 

Creates an ellipse or an elliptical arc 

AutoCAD2002 helps drawing a perfect ellipse or elliptical curve using this command. There are two different ways in defining an ellipse: (a) you define the full length of one axis and half-length of the other axis. (b) define the center point of the ellipse (the point where to exes intersect with each other) and half-length of other two exes. 

Command: _ellipse 

Specify axis endpoint of ellipse or [Arc/Center] : Use one of the point fixing methods or enter an option 

Axis Endpoints  

Draw > Ellipse > Axis, End 

This is the first step towards defining the first axis. The two end points of the axis are specified. When the first point is specified in the above option, it prompts for the second point. 

Specify other endpoint of axis: Use one of the point fixing methods 

Here, there is not distinction of major or manor axes of an ellipse. Depending on the distance you specify one could be the major axis of an ellipse and other could be the minor axis. AutoCAD 2002 doesn’t make any difference between these two. 

After the first axis of the ellipse is defined, AutoCAD 2002 gives you two options to define the length of the other axis. The first one is to define half-length of the other axis. 

Specify distance to other axis or [Rotation] : specify a distance 

This defines the second axis as the distance from the center of the ellipse (midpoint of the first axis that you defined earlier) in a direction perpendicular to the first axis.

The Rotation option defines the major to minor axis ratio of the ellipse by rotating an imaginary circle about the first axis you defined by the given rotation angle. The higher the value, the greater is the ratio of minor to major axis. Entering 0 defines a circle. Rotation around major axis: specify a point or enter a value 

Specify distance to other axis or [Rotation]: R 

Specify rotation around major axis : Specify an angle

Center, Axis Endpoints

Draw > Ellipse > Center 

You can start from the center point of an ellipse. After the definition of the center point, AutoCAD 2002 proceeds in a similar way we learned above. 

Command: _ellipse 

Specify axis endpoint of ellipse or [Arc/Center]: c

Specify center of axis: Specify a distance 

Specify distance to other axis or [Rotation]:  Specify a distance or angle 

Arc 

Draw > Ellipse > Arc

Creates an elliptical arc. AutoCAD 2002 constructs an imaginary ellipse using the methods we discussed above. Then the parameters about the arc are prompted for user input. The following sequence shows how a simple elliptical arc could be constructed. 

Command: _ellipse 

Specify axis endpoint of ellipse or [Arc/Center] :a 

Specify axis endpoint of elliptical arc or [Center]: Use one of the point fixing methods 

Specify other endpoint of axis: use one of the point fixing methods 

Specify distance to other axis or [Rotation] : Specify a distance 

Specify start angle or [Parameter]: Specify an angle or enter an option 

Specify end angle or [Parameter/Included angle]: Specify an angle or enter an option 

To specify start angle, you could enter a numeric value, in which case, AutoCAD 2002 measures the angle form the angle of the first axis you defined. 

Parameter requires the same input as start angle. 

Specify start angle or [parameter]: p

Specify start parameter or [Angle]: Enter a value or specify an angle 

Specify end parameter or [Angle/Included angle]: Enter a value or specify an angle 

Specify end parameter or [Angle/Included angle]: Enter a value or specify an angle 

Construction Line/ Xline 
Draw > Construction Line or type xl
Creates an infinite line 

Xline is a linear object, which starts at infinite and ends at infinite, or we can say that it is a line, which has no start or end point but passes through a specified point. These lines are used for projections.

Command: _xline 

Specify a point or [hor/ ver /ang/ bisect /offset]: use one of the point fixing methods or enter an option 

Specify through point: use one of the point fixing methods or enter 

Specify through point: use one of the point fixing methods or enter 

Specify two points through which the xline should pass, AutoCAD 2002 takes the first point on the line specified through the option specify a point, then prompts you for the second point on the xline through the option specify through point. 

AutoCAD 2002 goes on prompting you for the second point on the xline through the option spectfy through point and continues to draw xline with the first point as command and point as entered each time. Press enter to exit the command.

Hor/ Ver 

Creates a horizontal / vertical xline passing through a selected point.

Specify through point: use one of the point fixing methods 

AutoCAD 2002 places the xline parallel to the X axis or Y axis. 

Ang 

Creates an xline at a specified angle.

Enter angle of xline (0) or [Reference]: specify an angle

Specify through points: use of the point fixing methods 

Specifies the angle at which to place the lines then specify the point through which is should pass. AutoCAD2002 places a xline through the specified point, using the specified angle.

Reference 

When it is required to draw a xline whose angle is with reference to an exit line object, use the reference option and select the reference line and specify the offset angle, the angle is measured counterclockwise from the reference line. 

Select a line object: Use one of the object selection methods 

Enter angle of xline <0>: Specify n angle 

Specify through point: Use one of the point fixing methods 

AutoCAD 2002 places an xline through the specified point, where the angle of the xline is calculated by adding the specified offset angle with the angle of selected reference line.

Bisect 

Bisect option calculates the angle of the xline by bisecting an angle specified by three points 

Specify angle vertex point: Use one of the point fixing methods  

Enter angle start point: Use one of the point fixing methods 

Specify angle end point: Use one of the point fixing methods

The xline through the vertex point with an angle such that it bisects the angle between the start points, vertex point and end point. 

.

Offset 

Creates an xline parallel to another object. 
Specify offset distance or [through] <through>: Specify a value or enter T for through 

Offset distance 

Specifies the distance the xline is offset selected object. 

Select a line object: pick a line object or press enter to end the command 

Specify side to offset: use one of the point fixing methods

Through  

Creates a xine object: offset from a line and passing through a specified point.

Specify a line object: pick a line object or press enter to the command.

Specify through point: specify the point (p) through which you want the xline to pass.

Multi Line/ MLine 

Draw >Multiline or type ml
Creates multiple parallel lines 

To draw walls in a civil engineering drawing or piping lines in a P & I drawing, we often need several parallel lines. If we use simple line command, we need to take multiple offsets and cleaning up the corners and junctions world become a big mess. AutoCAD 2002 gives an elegant way of doing such work: the mline command. This draws several parallel lines (a maximum of 16lines), that are placed at user defined distance apart and each line can be of different linetype.

Command: _mline 

(Current settings: justification =top, scale =1.00, style=standard)
Specify start point or [justification/scale /style]: use one of the point fixing methods

Specify next point: use one of the point fixing methods 

Specify next point or [undo]:use one of the point fixing methods

Specify next point or [close/undo]: use one of the point fixing methods

AutoCAD 2002 draws a multiline segment to this point using the current multiline style and continues to prompt for points. Entering u undoes the last vertex point the multiline. If you create a multiline with two or more segments, AutoCAD 2002 displays a prompt that includes the close the multiline.

Justification

Determines how the multiline is draw between the points you specify. 

Enter justification type [top/zero/ bottom] <top>: Enter an option 

Top  

Draws the multiline below the cursor, so that the line with the most positive offset specified points.

Zero                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

Draws the multiline below with its origin centered at the cursor, so that the MLSTYLE element properties offset of 0.0 is at the specified points.  
Bottom 

Draws the multiline above the cursor, so that the line with the most negative offset is at the specified points.

Scale 

Controls the overall width of the multiline. This scale does not affect linetype scale

Enter mline scale <1.00>: Enter a value

The scale factor is based on the width established in the multiline style definition. A scale factor of 2 produces a multiiline twice as wide as the style definition. A negative scale factor flips the order of the offset lines - the smallest on top when the multiline is drawn from left to right. A negative scale value also alters the scale by the absolute value.  A scale of 0 collapses the mutiline into a single line. 

Style 

Specifies a style to use for the multiline. 

Enter mline style name or [?]: 

The name you enter must be a style that has already been loaded or that’s defined in a library file (mln) you’ve created. 

If you enter?, AutoCAD 2002 lists the loaded multiline styles.

Selecting and Editing Drawing Entities
Fillet

Modify >Fillet or type f 
Rounds and fillets the edges of objects

Fillet command rounds off the corner at the intersection of two objects by drawing an arc. The intersecting object could be trimmed off as necessary to from a smooth tangential fillet. If the objects are not physically intersecting with each other, but an extension of one or both of the objects could form an intersection, then AutoCAD2002 extends them as necessary to form a fillet. If both the objects are parallel to each other, AutoCAD2002 dose a special case of filleting called cap filleting. Here, the radius is taken as half-length of the perpendicular distance between the two objects. Xlines cannot be filleted. 

Command: _fillet 

Current settings: mode =trim, radius =0.5000

Select first object or [polyline/ radius/trim]: use one of the object selection methods or enter an option. 

Select second object: use one of the object selection procedures 

Radius  

Defines the radius of the fillet arc. The value specified becomes the current radius for subsequent fillet commands. The existing fillet arcs are not affected by a change in this value

Command: _fillet

Current settings: mode =radius =0.5000

Select first object or [polyline/radius / trim]: r 

Specify fillet radius <0.5000>: enter a distance.

Polyline

AutoCAD 2002 inserts fillet arch at each vertex of a 2D polyline where two line segments meet. If there is an arc segment separating two line segments, then the arc is replaced by the fillet. 

Select 2Dpolyline: select a polyline

Trim   

This controls whether AutoCAD2002 trims the selected edges to the fillet arc endpoints or not. 

Enter trim mode option [trim/ no trim]: enter an option 

Chamfer

Modify > chamfer or type cha
Bevels the edges of objects
Chamfer command draws a line at the corner between two selected lines, if the lines do not intersect it extends the lines and if they intersect the lines extending beyond the chamfer line can be trimmed or left as it is by the trim mode. The chamfer line is defined by the offset distance along the selected lines from the intersecting corner of the lines or by defining the angle and distance from the corner.

Command:_chamfer

(TRIM mode) current chamfer Dist1=1.0000, Dist2= 2.0000

Select first line or [polyline /Distance /Angle/ Trim /Method]: use one of the object selection procedures or enter an option.

Select second line: use one of the object selection methods

Specifies the first two edges required to define a 2d chamfer. If the two lines you select are polyline segments, they must be adjacent or separated by a line or an arc segment. If a line or an arc segment separates them, AutoCAD2002 deletes the segment and replaces it with a chamfer line.

Polyline 

Chamfers the entire 2D polyline. AutoCAD 2002 chamfers the intersecting line segments at each vertex of the polyline. Chamfers become new segment of the polyline. 

Select 2D polyline: use one of the object selection methods and select a polyline 

Distances 

Sets the chamfer from the selected edge. The distances can be uniform or varying AutoCAD2002 sets the first distance to the first selected line and the second distance to the second selected line. 

Specify first chamfer distance <1.0000>: specify a value or pick two points on screen to define the distance.

Specify second chamfer distance <2.0000>: specify a value or pick two points on screen to the distance.

After you specify the chamfer distance, use chamfer command again to chamfer. If you set both to zero, AutoCAD2002 extends or trims the two lines so that they end at the same point.

Angle 

Sets the chamfer distance using a chamfer distance for the first line and an angle for the second.  

Specify chamfer angle length on the first line <1.0000>: specify a value or pick two points on screen to define the distance.

Specify chamfer angle form the first line <0>: specify an angle or pick two points on screen to define the angle. 

Method

Controls whether AutoCAD 2002 uses the distance or angle method to create the chamfer.

Enter trim method [Distance/Angle] < Angle>: Enter an option

Trim 

Controls whether AutoCAD 2002 trims the selected edges to the chamfer line endpoints.

Enter Trim mode option [Trim/No trim] <Trim>: Enter an option

Mirror
Modify – Mirror or type mi
Creates a mirror image copy of objects

In some cases we need to create objects that are symmetrical about a particular axis. In such cases, mirror command comes in handy. You can just draw one half of the model and AutoCAD 2002 can produce the other half by mirroring what you have done. This way you can reduce your effort by one half and so save time. If the object is symmetric about multiple axes, then that many fold you can save time by doing multiplying mirroring.

Command : _mirror 

Select objects : use any object selection method 

Specify first point of mirror line : use any of the point fixing methods 

Specify second point of mirror line : Use any of the point fixing methods 

Delete source objects? [Yes /No] <N> : Enter an option

Stretch

Modify >stretch or type s
Moves or stretches objects

We encountered situations where it is required to change the size of an object, where the change in size is limited to one direction. In such situations AutoCAD 2000 provides a command called STRETCH which stretches or compresses the selected object in the direction and magnitude specified by the user.

Command:_stretch

Select objects to stretch by crossing- window or crossing-polygon…

Select object: select objects by any crossing object selection methods

Specify base point or displacement: Use of the point fixing methods

Specify second point of displacement: Use one of the point fixing methods

Selection of the object should be done using any crossing object method (i.e. crossing-window or crossing- polygon)

As the description says, this command either stretches or moves the object depending on how the object are got selected. 

The objects were selected with crossing window. 1 and 2 are the base and second points respectively. Considering the result of stretching, following three points are obvious:
· Objects that are completely within the crossing window are moved.

· Objects that are completely outside the window are intact
· For the objects that cross the window, endpoints within the window are moved and end endpoints outside the window are intact and so the objects are got stretched. 
If a second point is entered, the objects are stretched from the base point to the second point. If you press at the Specify second point of displacement: prompt, AutoCAD 2002 treats the X and Y values given at the Specify base point or displacement: as the displacement for stretching.
Rotate
Modify > Rotate or type ro
Rotate the Objects
By default it rotates counterclockwise. 
Command:_rotate
(Current positive angle in UCS: ANGDIR = counterclockwise   ANGBASE = 0)
Select objects: Use one of the object selection method

Specify base point: use any of the point fixing methods 

Specify rotation angle or [Reference]: Enter required angle for rotation 
Reference (it helps to guide the angular value with reference to the existing value)
Specify rotation angle or [Reference]: Type R
Specify the reference angle <0>: Enter the existing value
Specify the new angle: Enter a new value 
Scale
Modify > Scale or type sc 
Helps to enlarge or reduce the objects
Command:_scale
Select objects: Use one of the object selection method

Specify base point: use any of the point fixing methods 

Specify scale factor or [Reference]: Enter required scale factor 

Reference (it helps to guide the scale with reference scale to the existing scale)
Specify scale factor or [Reference]: Type R
Specify  reference length <1>: Enter the existing length or value
Specify new length: Enter a new length or value
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